
 

 

  

 

Manual - RTR 
Momentum Trend All 
Symbols - Expert 
Advisor Setup 
Manual v1.0 
 
This manual will get you set up in 15 minutes, Expert 
Advisors for live trading or back testing In the MT5 Strategy 
Tester.  
 
Retail Trading Realities Ltd 
5/30/2025 
 



Manual - RTR Momentum Trend All Symbols - Expert Advisor Setup 
 

 
© 2025, Retail Trading Realities Ltd 

momentum-trend.com 
 

 

page Content 

2 Enable Web Requests in MetaTrader 5. 

2 Expert Advisor Directory. 

3 Load EA on Chart. 

4 SET File Load/Save. 

6 Change Risk Settings. 

7 Add Symbols in Market Watch. 

8 VPS (Virtual Private Server) / MT5 VPS Optimization. 
 

11(Extra) How to use MT5 Strategy Tester, for back testing, load Set 
files etc... 

15 EA Inputs: Description & Explanation 

17 Single symbol settings for RTR Momentum Trend All Symbols 
Unlimited 

20 ERROR 4805 – Fix – Solution! Custom indicator Error [4805] 

21 Contact 

  



Manual - RTR Momentum Trend All Symbols - Expert Advisor Setup 
 

 
© 2025, Retail Trading Realities Ltd 

momentum-trend.com 
 

Allow EA Web Requests  

MT5 Terminal > Tools> Options> Expert Advisors (Tab) 

 >  

> type in “https://momentum-trend.com” , then Press OK. 

 

Expert Advisor Directory 

File > Open Data Folder > MQL5 > Experts> put your Expert Advisor (EA) in this folder. 

       

>Open Data Folder ‘Ctrl+Shift+D’  
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>MQL5 Folder  

>Experts Folder  

Load EA on Chart  
MT5 Terminal> View> Navigator> Expert Advisors 

 

Now File> New Chart > “find your chart symbol e.g. USDJPY” > drag and drop EA from Navigator onto 
the chart>check Allow Algo Trading> ”type in your password” (required) > click load> Load SET file 
usdjpy_m15 > change chart time frame to M15. 
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Note: Every time you load an EA onto a 
Chart you must give it a new Magic 
Number i.e. 56823798. 
 
Magic Number is in the inputs tab; make sure it 
is at least 5 digits long. 
Every Instance of an Expert Advisor must have a 
new unique Magic Number. 
So that there is no confusion between strategies 
that have the same symbol, but not necessarily 
the same settings.  

> drag and drop EA from the Navigator 
onto the chart   . 

 

> check “[  ] Allow Algo Trading” 
(Common Tab). 

 

 click “Load”    . 

 
 

 Load the SET file for your symbol  
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 Now change the Time Frame of the Chart to match the SET File name, i.e. usdjpy_m15, must 
be placed on M15 chart. Right click on the chart > Timeframes > M15 

 If you have multi symbol EA - an Expert Advisor that trades multiple Symbols from 1 chart. 
Please drop the EA onto a Forex 5 Minute Chart (M5).  

 If you are trading Conservative Settings set files place EA on H1 chart ( 1 hour), because 
lowest timeframe is H1 . 
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That is done, now you must change the risk in all SET Files. (Please Read the manual) 

Change Risk Settings 

 

 

The ‘Risk %’ input is the percentage % of account balance the EA will risk per trade. 

1.0 = 1.0% is the absolute maximum risk and should only be used if you are trading only 1 
symbol i.e. GOLD/USD. 

If you are trading 5 symbols (that is 5 charts with attached EAs) then the “Risk %” input on 
all Charts should be absolute maximum = 1% ÷ 5, which is equal to 0.20  

You would type in “0.20”, Risk % =0.20. 

I am only using half of that, in my main Index Signal. 

For Crypto I am using full Risk of = 1% ÷ (𝑛𝑢𝑚𝑏𝑒𝑟 𝑜𝑓 𝑠𝑦𝑚𝑏𝑜𝑙𝑠) , however I have a smaller 
initial deposit, that is 5 times smaller than my deposit for my main Darwinex account (non-
crypto). 

 
Okay, now you can enjoy your trading.  
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Add Symbols to Market Watch Can’t Find your Symbol, stock ticker, Chart? 
 

If you cannot find your Ticker Symbol, MT5 Terminal > View > Market Watch…> right click any ticker 
inside Market Watch > Show All,  

   

After you have all your desired symbols, return to Market Watch> right click any ticker > Hide All.  

This way Market Watch is not running in the background using up CPU resources, looking at ticker 
quotes you are not interested in. 

(Also While you are in Market Watch > Right Click any ticker> Columns > Spread. Shows all Bid-Ask 
spread in points.) 
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How to setup EA with a Windows Server VPS 
 

Windows Server 2012/2019/2022 

Summary: Windows Server 2012 – is like Windows 7 PC, Windows Server 2019/2022 – is like 
Windows 10 PC. 

ForexVPS.net Offer: https://www.forexvps.net/partner/retailtradingrealities 

We also recommend https://www.mql5.com/en/vps, fastest ping. 

Download and Install your MT5 like you would on a Windows 10/11 PC. 

 

Copy my Settings: 

MT5 Terminal > Tools> Options > Charts 

 

MT5 Terminal > Tools> Options > Expert Advisors 
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MT5 Terminal > Tools> Options > Server 

 

MT5 Terminal > Tools> Options > Community 
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Final VPS step: 

Once you have all Charts, Time Frames and Symbols you want use in view, go to View>Market 
Watch> right click any ticker, click > ‘Hide All’. 
This will stop MT5 reading quotes in the background, from tickers/symbols the EA is not trading on.  

 

MT4/5 AUTO START for VPS: 

 

We at Retail Trading Realities are using ForexVPS.net, and they 
have this feature, where you can use their .exe program to Auto-
Start all of your MT4/5 Terminals every time the server restarts. 
Remember You will have to restart your Server every now and then, 
but also your VPS provider will restart servers for maintenance. 
 
You will have to enable this manually by reading the steps in the 
.ODT text file (usually on the Desktop). 
 
Other Forex VPS providers also have this feature (nearly all of 
them). 
 
You won’t need to do this if you have a server provided by 
MetaQuotes from MQL5.com . 
 
Do not use a Linux server with MT4/5. 
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Strategy Tester & Optimizer in MT5 – What is it? 
 

MT5 Terminal > View > Strategy Tester 

 

 

To back test an Expert Advisor, you can run a Single tests, and Optimizations in MT5 Strategy Tester.  

Optimizations will look at the input parameters (see Inputs Tab of Expert) you have selected and all 
the values you wanted the EA to be tested for. It will test all possible combinations of settings. Be 
careful it is recommended you choose only up to 3 inputs for optimization. The more inputs selected 
the more chance of ‘curve fitting’.  

If you choose too many inputs and step settings, i.e. 2,000 combinations, MT5 will revert to a 
‘genetic algorithm’, to find best settings, it won’t test every combination. It will test a sample and try 
to find the best settings using their in-house secret algo. 
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Choose Symbol and the Chart Period you would have placed the Expert Advisor on, if it were live 
trading.  

The Yellow Dollar sign Icon  is very important, to new users of MT5 strategy tester.  

You will need to click on this Icon, to change the selected Symbols’ defaults for a correct back test. 
Its’ default is either; (No Leverage) ‘CFD’ and ‘Forex No Leverage’. Here you will change it to ‘CFD 
Leverage’ or ‘Forex’.  

 

You can also change the default Direction from ‘Full Access’ to ‘Long only’ or Short Only’, this change 
in direction set here, will only work for back tests and optimizations, this will not change in Live or 
Demo trading.  

Modelling Data: using Open Prices (the RTR Momentum Trend Expert is coded On Open Prices –
OnBar() ), or simulated ticks called ‘Every Tick’, ‘Every tick based on Real Ticks’ include Broker 
historical Bid-Ask Spread, there is also a 1 minute bar option for the data.  

Note: Back tests that have Real Tick selected will take a lot longer than on ‘Open prices’ modelling. 
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I suggest Optimizations using ‘Open Prices’, then Run Single Back test using ‘Real Ticks’. 

 

START, STEP, STOP: 
START, is the first value of the input that will be tested. 

STEP, is the increment, it will add to the previous value of the input that was tested, and will run a 
new test.  

STOP, is the Last value of the input that will be tested for. 

So in this Example we have selected only 1 input for Optimization, Profit Threshold. 

We Start at 8, STEP (increment)= 2, FINISH at 20. 

We will test Profit Threshold at; 8, 10, 12, 14, 16, 18, 20.  

And there are 7 Passes (8 to 20).  
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Source: https://www.metatrader5.com/en/terminal/help/algotrading/strategy_optimization  
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EA Inputs: Description & Explanation 
 

 
Inputs Default Description 

Magic Number 123456 
Expert Advisor unique  ID, each time you load it 
on a chart give it a new 6-7 digit number 

Enter Symbols USDJPY|XAUUSD|NDX|COST|META 
|TSLA|MSFT 

To enter multiple symbols, separate by typing a 
'|' after your symbol, you don't need to put it 
after the last symbol. Eneter "CURRENT" if you 
want the symbol the EA is currently on . Or Type a 
single symbol . 

TimeFrames 
  

Two TF Mode 
true|false|false|false|false 
|false|false 

'true' for Two timeframe mode or 'false' Three 
timeframe mode . On Two timeframe mode 
middle timeframe is ignored. 

Highest TF D1|D1|D1|H4|H4|D1|H4 Highest chart that references the trend 

Middle TF H4|H2|H4|M20|H1|H3|H1 
Middle timeframe, is for the pullback (not in Two 
timeframe mode) 

Lowest TF M15|M15|M15|M5|M5|M5|M5 
Lowest time frame this is the execution 
timeframe where SL and TP is calculated. 

Take Profit 
Multiplier   
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Profit Threshold 18|16|10|14|18|14|14 
Profit level is a multiplier of Stop Loss, there is 
also a higher timeframe trailing stop. 

Direction 
  

Direction: 
Both/Long/Short 

Long|Both|Both|Long|Long 
|Long|Long  

Spread Filter 
  

Max Spread 0|0|0|0|0|0|0 

If you type in a number higher than 0 then no 
trades will be executed if the spread displayed in 
MarketWatch window is higher than the number 
set. 

Entry deviation 
(multiplier of spread) 

3|3|3|3|3|3|3 
Maximum slippage allowed the number is 
multiplier of current spread. 

Order Type 
  

MARKET/LIMIT order 
MARKET|MARKET|MARKET|MARKET 
|MARKET|MARKET|MARKET  

Risk Management 
MODE   

Risk_Management Normal 

Normal - example if risk % is set to 1, each trade 
will be risking 1% of account balance.  Prop Firm 
Mode, will try and never hit Prop Firm maximum 
Drawdown equity, which the user sets. Backtest 
Prop mode must only be used in back testing. 

Prop Firm Max 
DrawDown 

9000 
Does not apply to Normal Mode, Prop Firm Live 
and Back test mode this applies to. 

Lot Sizes 
  

Fixed Lot Size 0 
i.e. 1.40 lots, for every trade, set all others to 0, if 
using this mode. 

Risk % 1 I.e. Risk 1% of account balance per trade, set all 
others to 0, if using this mode. 

Fixed Dollar Amount  0 
i.e. 110 = Risk $110 dollars per trade, set all 
others to 0, if using this mode. 

Custom Trade 
Comment   

custom comment 
 

i.e. "Sarah’s Safe mode trades" 

Limit order Settings 
  

limit offset 1.0 
Only works if LIMIT is selected, offset is a 
multiplier of the spread, so a buy limit will be 
executed at current price minus the spread. 

expiry_hours 120 
Only works if LIMIT is selected, how many hours 
you want limit orders to exist. 

Day of Week Filter true  
enter true or false. 'false' if you don't want EA to 
open trades on a given day 

Hour of Day Filter 
  

Start Hour 0000 Self-explanatory 

Last Hour 2300 Self-explanatory 
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Single symbol settings for RTR Momentum Trend All Symbols 
Unlimited  
 USDJPY AUDJPY EURJPY CHFJPY 

Magic Number 123456 123456 123456 123456 
Enter Symbols USDJPY AUDJPY EURJPY CHFJPY 
TimeFrames     
Two TF Mode true  FALSE false  true  
Highest TF D1 D1 D1 W1 
Middle TF H4 H4 H1 H4 
Lowest TF M15 M15 M20 H1 
Take Profit Multiplier     
Profit Threshold 16 14 18 16 
Direction     
Direction: Both/Long/Short Long Long Long Long 
Spread Filter     
Max Spread 0 0 0 0 
Entry deviation (multiplier of 
spread) 

3 3 3 3 

Order Type     
MARKET/LIMIT order MARKET MARKET MARKET MARKET 
     
...All other settings you can leave as default or change as you 
wish 

 

     
 USDJPY USDJPY XAUUSD NDX 
Magic Number 123456 123456 123456 123456 
Enter Symbols USDJPY USDJPY XAUUSD NDX 
TimeFrames     
Two TF Mode true  true  false  false  
Highest TF W1 D1 D1 D1 
Middle TF H4 H4 H2 H4 
Lowest TF M30 H1 M15 M15 
Take Profit Multiplier     
Profit Threshold 17 12 16 10 
Direction     
Direction: Both/Long/Short Long Long Both Both 
Spread Filter     
Max Spread 0 0 0 0 
Entry deviation (multiplier of 
spread) 

3 3 3 3 

Order Type     
MARKET/LIMIT order MARKET MARKET MARKET MARKET 
     
...All other settings you can leave as default or change as you 
wish 
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 ADBE COST META MSFT 
Magic Number 123456 123456 123456 123456 
Enter Symbols ADBE COST META MSFT 
TimeFrames     
Two TF Mode false  false  false  false  
Highest TF D1 H4 H4 H4 
Middle TF M20 M20 H1 H1 
Lowest TF M5 M5 M5 M5 
Take Profit Multiplier     
Profit Threshold 16 18 18 14 
Direction     
Direction: Both/Long/Short Long Long Long Long 
Spread Filter     
Max Spread 0 0 0 0 
Entry deviation (multiplier of 
spread) 

3 3 3 3 

Order Type     
MARKET/LIMIT order MARKET MARKET MARKET MARKET 
     
...All other settings you can leave as default or change as you 
wish 

 

     
 TSLA NVDA ETH ETH 
Magic Number 123456 123456 123456 123456 
Enter Symbols TSLA NVDA ETH ETH 
TimeFrames     
Two TF Mode false  false  false  FALSE 
Highest TF D1 D1 D1 D1 
Middle TF H3 H4 H4 H4 
Lowest TF M5 M5 M20 M15 
Take Profit Multiplier     
Profit Threshold 14 18 14 16 
Direction     
Direction: Both/Long/Short Long Long Both Long 
Spread Filter     
Max Spread 0 0 0 0 
Entry deviation (multiplier of 
spread) 

3 3 3 3 

Order Type     
MARKET/LIMIT order MARKET MARKET MARKET MARKET 
     
...All other settings you can leave as default or change as you 
wish 

 

     
 BTCUSD SOLUSD LTCUSD LNKUSD 
Magic Number 123456 123456 123456 123456 
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Enter Symbols BTCUSD SOLUSD LTCUSD LNKUSD 
TimeFrames     
Two TF Mode false  true  false  false  
Highest TF D1 D1 D1 D2 
Middle TF H1 H3 H1 H3 
Lowest TF M15 M30 M20 M15 
Take Profit Multiplier     
Profit Threshold 14 18 16 10 
Direction     
Direction: Both/Long/Short Long Long Long Long 
Spread Filter     
Max Spread 0 0 0 0 
Entry deviation (multiplier of 
spread) 

3 3 3 3 

Order Type     
MARKET/LIMIT order MARKET MARKET MARKET MARKET 
     
...All other settings you can leave as default or change as you 
wish 

 

     
 DOTUSD    
Magic Number 123456    
Enter Symbols DOTUSD    
TimeFrames     
Two TF Mode true     
Highest TF D1    
Middle TF H4    
Lowest TF M15    
Take Profit Multiplier     
Profit Threshold 12    
Direction     
Direction: Both/Long/Short Long    
Spread Filter     
Max Spread 0    
Entry deviation (multiplier of 
spread) 

3    

Order Type     
MARKET/LIMIT order MARKET    
     
...All other settings you can leave as default or change as you 
wish 
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ERROR 4805 – Fix – Solution! 
ERROR 4805 – cannot load custom indicator ‘::Indicators\RTR_Trend.ex5’ 
[4805] 
 

 
This is not a coding error. This is an error to do with your CPU and MT5 cache 
(temporary memory). 
This is only a problem with the multi-symbol EAs; old CPUs, old chipsets, Computers with 
less than 8GB Ram. 
This problem is easily solved, once solved you won't have a problem as cache will remember 
correctly. 
This can happen in 1) the Strategy Tester or 2) when loading on a chart for Live trading. 
Both have different Solutions. 

(1) MT5 Strategy Tester Solution  
- Close down all programs running on your Operating System (or restart your PC). 
-Restart your MT5 terminal. Make sure your data goes far enough back for the symbols and 
custom dates you have chosen.  View > Symbols > Bars, to see you historic data. 

(2) MT5 Live Trading Solution (EA on a Live chart)  
-Restart your PC/Laptop. Open MT5 Terminal, no other programs. MT5 will open with the 
last settings you closed with and we want a new cache (temp memory). 
 
File > Profiles > Save As...> name your new profile > close all charts > open a new chart i.e. 
EURUSD, just 1. 
 
Drag & Drop EA onto the chart M5 (or H1 for conservative set files),  
There should only be 1 chart open> Load SET Files> OK 
Now do this for other charts you want to add and remember to add unique Magic Number 
to the new EA. 
Now you have loaded all your EAs with No 4805 Errors. Restart your MT5 terminal and you 
will see it will ALWAYS load your EAs with no problems, that is because the profiles cache 
(temp memory) is set correctly! 
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Retail Trading Realities Ltd 
Company number 15221732 
 
71-75 Shelton Street,  
Covent Garden,  
London, WC2H 9JQ, 
United Kingdom 
 
W: https://momentum-trend.com  
E: contact@retailtradingrealities.com 
 


